Skip Navigation Linkssystem-requirements System Requirements

System Requirements

​The ISCEBS website supports many popular web and mobile browsers. To experience the ISCEBS website in the most safe and reliable way, we highly recommend upgrading to the latest version of one of the following browsers:

  • Microsoft Internet Explorer 11
  • Microsoft Edge
  • Google Chrome
  • Mozilla Firefox
  • Apple Safari (on OS X 10.9 and above)

The ISCEBS website no longer fully supports Microsoft Internet Explorer (IE) 10, and older IE browser versions. For Mac users, Safari can only be used on OS X Mavericks (version 10.9) and above. This is due to an effort to achieve the most secure and compliant experience for our users. Please consider upgrading IE to a newer version, or use an alternate browser that is listed above.


Note: For IE10 users, if you are unable to upgrade your IE version, trying the following steps may help:

  1. Select "Tools" > "Internet Options".
  2. Go to the "Advanced" tab.
  3. Scroll down to the "Security" section.
  4. Locate and check "Use TLS 1.1" and "Use TLS 1.2".
  5. Press OK, restart IE.